import re
regex = re.compile(r"\(([a-z -]+)\w+?(\d+)\W+\1\w+\)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("(beginner_post12 - beginner_baseline)\n"
"(intermediate_post5 - intermediate_baseline)\n"
"(framework notes_posttest4 - framework notes_baseline)\n"
"(note-taking instruction_posttest33 - note-taking instruction_baseline)\n")
subst = "Gain_$2($1)"
result = regex.sub(subst, test_str)
if result:
print(result)