using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([a-z -]+)\w+?(\d+)\W+\1\w+\)";
string substitution = @"Gain_$2($1)";
string input = @"(beginner_post12 - beginner_baseline)
(intermediate_post5 - intermediate_baseline)
(framework notes_posttest4 - framework notes_baseline)
(note-taking instruction_posttest33 - note-taking instruction_baseline)
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}