const regex = /(?<=connectionId=)\d+/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=connectionId=)\\d+', 'gi')
const str = `http://localhost:10001/Member/GetConnection?всякаяНенужнаяХуита&connectionId=100500&всякаяНенужнаяХуита`;
const subst = `123`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);