re = /(?<=connectionId=)\d+/i
str = 'http://localhost:10001/Member/GetConnection?всякаяНенужнаяХуита&connectionId=100500&всякаяНенужнаяХуита'
subst = '123'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result