import re
regex = re.compile(r"(?<=connectionId=)\d+", flags=re.IGNORECASE)
test_str = "http://localhost:10001/Member/GetConnection?всякаяНенужнаяХуита&connectionId=100500&всякаяНенужнаяХуита"
subst = "123"
result = regex.sub(subst, test_str)
if result:
print(result)