$re = '/(?<=connectionId=)\d+/i';
$str = 'http://localhost:10001/Member/GetConnection?всякаяНенужнаяХуита&connectionId=100500&всякаяНенужнаяХуита';
$subst = "123";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;