import Foundation
let pattern = #"(?<=connectionId=)\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"http://localhost:10001/Member/GetConnection?всякаяНенужнаяХуита&connectionId=100500&всякаяНенужнаяХуита"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"123"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)