use strict;
my $str = 'http://localhost:10001/Member/GetConnection?всякаяНенужнаяХуита&connectionId=100500&всякаяНенужнаяХуита';
my $regex = qr/(?<=connectionId=)\d+/ip;
my $subst = '123';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";