using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A([^\r\n]*\n){1}";
string substitution = @"";
string input = @"first
second
third
fourth
bla
bla
bla bla bla";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}