use strict;
my $str = 'first
second
third
fourth
bla
bla
bla bla bla';
my $regex = qr/\A([^\r\n]*\n){1}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";