import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A([^\\r\\n]*\\n){1}";
final String string = "first\n"
+ "second\n"
+ "third\n"
+ "fourth\n"
+ "bla\n"
+ "bla\n"
+ "bla bla bla";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}