#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*)(1999 - Pizza & Cheese)(.*)(\..*)"
Local $sString = "Monthly YTD Profit Report - 1999 - Pizza & Cheese- Papa John Unit 45 en-US.pdf"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)