$re = '/(.*)(1999 - Pizza & Cheese)(.*)(\..*)/';
$str = 'Monthly YTD Profit Report - 1999 - Pizza & Cheese- Papa John Unit 45 en-US.pdf';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;