const regex = /(.*)(1999 - Pizza & Cheese)(.*)(\..*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(1999 - Pizza & Cheese)(.*)(\\..*)', '')
const str = `Monthly YTD Profit Report - 1999 - Pizza & Cheese- Papa John Unit 45 en-US.pdf`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);