re = /(.*)(1999 - Pizza & Cheese)(.*)(\..*)/
str = 'Monthly YTD Profit Report - 1999 - Pizza & Cheese- Papa John Unit 45 en-US.pdf'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result