import Foundation
let pattern = #"(.*)(1999 - Pizza & Cheese)(.*)(\..*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Monthly YTD Profit Report - 1999 - Pizza & Cheese- Papa John Unit 45 en-US.pdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}