using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(1999 - Pizza & Cheese)(.*)(\..*)";
string substitution = @"";
string input = @"Monthly YTD Profit Report - 1999 - Pizza & Cheese- Papa John Unit 45 en-US.pdf";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}