use strict;
my $str = 'Monthly YTD Profit Report - 1999 - Pizza & Cheese- Papa John Unit 45 en-US.pdf';
my $regex = qr/(.*)(1999 - Pizza & Cheese)(.*)(\..*)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";