using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Yours sincerely,\s+(?<name>[^\n]+)\s+(?<email>[^\n]+)\s+(?<address>[^\n]+?(?<postcode>\d+))";
string input = @"Yours sincerely,
Persons Name
test@example.com.au
Sydney, New South Wales 2152";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}