const regex = /Yours sincerely,\s+(?<name>[^\n]+)\s+(?<email>[^\n]+)\s+(?<address>[^\n]+?(?<postcode>\d+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Yours sincerely,\\s+(?<name>[^\\n]+)\\s+(?<email>[^\\n]+)\\s+(?<address>[^\\n]+?(?<postcode>\\d+))', 'gm')
const str = `Yours sincerely,
Persons Name
test@example.com.au
Sydney, New South Wales 2152`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}