package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Yours sincerely,\s+(?<name>[^\n]+)\s+(?<email>[^\n]+)\s+(?<address>[^\n]+?(?<postcode>\d+))`)
var str = `Yours sincerely,
Persons Name
test@example.com.au
Sydney, New South Wales 2152`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}