// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Yours sincerely,\s+(?<name>[^\n]+)\s+(?<email>[^\n]+)\s+(?<address>[^\n]+?(?<postcode>\d+))").unwrap();
let string = "Yours sincerely,
Persons Name
test@example.com.au
Sydney, New South Wales 2152";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}