re = /Yours sincerely,\s+(?<name>[^\n]+)\s+(?<email>[^\n]+)\s+(?<address>[^\n]+?(?<postcode>\d+))/m
str = 'Yours sincerely,
Persons Name
test@example.com.au
Sydney, New South Wales 2152'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end