$re = '/Yours sincerely,\s+(?<name>[^\n]+)\s+(?<email>[^\n]+)\s+(?<address>[^\n]+?(?<postcode>\d+))/m';
$str = 'Yours sincerely,
Persons Name
test@example.com.au
Sydney, New South Wales 2152';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);