#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((^\d+((\s)\d+)*$)|(^\d+(,)\d+)*$)"
Local $sString = "123,455" & @CRLF & _
"123 456" & @CRLF & _
"12,45 67" & @CRLF & _
"12 34,56" & @CRLF & _
"1 2 3 4" & @CRLF & _
"1,2,3 4" & @CRLF & _
"123, 56" & @CRLF & _
"12 ,356" & @CRLF & _
"3 4 5,89"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")