import re
regex = re.compile(r"((^\d+((\s)\d+)*$)|(^\d+(,)\d+)*$)", flags=re.MULTILINE)
test_str = ("123,455\n"
"123 456\n"
"12,45 67\n"
"12 34,56\n"
"1 2 3 4\n"
"1,2,3 4\n"
"123, 56\n"
"12 ,356\n"
"3 4 5,89")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")