re = /((^\d+((\s)\d+)*$)|(^\d+(,)\d+)*$)/m
str = '123,455
123 456
12,45 67
12 34,56
1 2 3 4
1,2,3 4
123, 56
12 ,356
3 4 5,89'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end