// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((^\d+((\s)\d+)*$)|(^\d+(,)\d+)*$)").unwrap();
let string = "123,455
123 456
12,45 67
12 34,56
1 2 3 4
1,2,3 4
123, 56
12 ,356
3 4 5,89";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}