import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((^\\d+((\\s)\\d+)*$)|(^\\d+(,)\\d+)*$)";
final String string = "123,455\n"
+ "123 456\n"
+ "12,45 67\n"
+ "12 34,56\n"
+ "1 2 3 4\n"
+ "1,2,3 4\n"
+ "123, 56\n"
+ "12 ,356\n"
+ "3 4 5,89";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}