$re = '/((^\d+((\s)\d+)*$)|(^\d+(,)\d+)*$)/m';
$str = '123,455
123 456
12,45 67
12 34,56
1 2 3 4
1,2,3 4
123, 56
12 ,356
3 4 5,89';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);