#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(x{1}y{1}|x{2}y{2}|x{3}y{3}|x{4}y{4})\b"
Local $sString = "xy -> valid" & @CRLF & _
"xxyy -> valid" & @CRLF & _
"xxxyyy -> valid" & @CRLF & _
"xyy -> not valid" & @CRLF & _
"xxy -> not valid"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")