use strict;
my $str = 'xy -> valid
xxyy -> valid
xxxyyy -> valid
xyy -> not valid
xxy -> not valid';
my $regex = qr/\b(x{1}y{1}|x{2}y{2}|x{3}y{3}|x{4}y{4})\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}