import re
regex = re.compile(r"\b(x{1}y{1}|x{2}y{2}|x{3}y{3}|x{4}y{4})\b", flags=re.MULTILINE)
test_str = ("xy -> valid\n"
"xxyy -> valid\n"
"xxxyyy -> valid\n"
"xyy -> not valid\n"
"xxy -> not valid")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")