import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(x{1}y{1}|x{2}y{2}|x{3}y{3}|x{4}y{4})\\b";
final String string = "xy -> valid\n"
+ "xxyy -> valid\n"
+ "xxxyyy -> valid\n"
+ "xyy -> not valid\n"
+ "xxy -> not valid";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}