$re = '/\b(x{1}y{1}|x{2}y{2}|x{3}y{3}|x{4}y{4})\b/m';
$str = 'xy -> valid
xxyy -> valid
xxxyyy -> valid
xyy -> not valid
xxy -> not valid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);