using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(x{1}y{1}|x{2}y{2}|x{3}y{3}|x{4}y{4})\b";
string input = @"xy -> valid
xxyy -> valid
xxxyyy -> valid
xyy -> not valid
xxy -> not valid";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}