// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(x{1}y{1}|x{2}y{2}|x{3}y{3}|x{4}y{4})\b").unwrap();
let string = "xy -> valid
xxyy -> valid
xxxyyy -> valid
xyy -> not valid
xxy -> not valid";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}