import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "s\\/(.+)\\/(.+)\\s";
final String string = "s/spambot/cool\n"
+ "s/that/this\n"
+ "s/you/everyone\n";
final String subst = "$1 is cooler than $2\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}