$re = '/s\/(.+)\/(.+)\s/';
$str = 's/spambot/cool
s/that/this
s/you/everyone
';
$subst = "$1 is cooler than $2\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;