re = /s\/(.+)\/(.+)\s/
str = 's/spambot/cool
s/that/this
s/you/everyone
'
subst = '$1 is cooler than $2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result