using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img.*?src=""([^""]+\?contextId[^""]+)""[^>]+>)";
string input = @"<img xmlns=""http://www.w3.org/1999/xhtml"" src=""http://10.206.38.34:8080/resource/resources/aktuelle_Ressourcen/eService/Bilder/uebersicht-router.png?contextId=eservice_1.0.0.qualifier"" alt=""Bild Übersicht Router"" title=""Übersicht Router"" />";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}