const regex = /(<img.*?src="([^"]+\?contextId[^"]+)"[^>]+>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<img.*?src="([^"]+\\?contextId[^"]+)"[^>]+>)', '')
const str = `<img xmlns="http://www.w3.org/1999/xhtml" src="http://10.206.38.34:8080/resource/resources/aktuelle_Ressourcen/eService/Bilder/uebersicht-router.png?contextId=eservice_1.0.0.qualifier" alt="Bild Übersicht Router" title="Übersicht Router" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}