re = /(<img.*?src="([^"]+\?contextId[^"]+)"[^>]+>)/
str = '<img xmlns="http://www.w3.org/1999/xhtml" src="http://10.206.38.34:8080/resource/resources/aktuelle_Ressourcen/eService/Bilder/uebersicht-router.png?contextId=eservice_1.0.0.qualifier" alt="Bild Übersicht Router" title="Übersicht Router" />'
# Print the match result
str.match(re) do |match|
puts match.to_s
end