#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^0-9-][0-9]{3}-[0-9]{2}-[0-9]{4}[^0-9-]"
Local $sString = "some document with 45-555-5462 in it" & @CRLF & _
"Another doc with 457-55-5462 in it" & @CRLF & _
"Doc with 4578-55-5462 in it" & @CRLF & _
"doc with 457-55-54623 in it" & @CRLF & _
"doc with 457-55-5462-23 in it"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")