import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^0-9-][0-9]{3}-[0-9]{2}-[0-9]{4}[^0-9-]";
final String string = "some document with 45-555-5462 in it\n"
+ "Another doc with 457-55-5462 in it\n"
+ "Doc with 4578-55-5462 in it\n"
+ "doc with 457-55-54623 in it\n"
+ "doc with 457-55-5462-23 in it";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}