using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^0-9-][0-9]{3}-[0-9]{2}-[0-9]{4}[^0-9-]";
string input = @"some document with 45-555-5462 in it
Another doc with 457-55-5462 in it
Doc with 4578-55-5462 in it
doc with 457-55-54623 in it
doc with 457-55-5462-23 in it";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}