$re = '/[^0-9-][0-9]{3}-[0-9]{2}-[0-9]{4}[^0-9-]/m';
$str = 'some document with 45-555-5462 in it
Another doc with 457-55-5462 in it
Doc with 4578-55-5462 in it
doc with 457-55-54623 in it
doc with 457-55-5462-23 in it';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);