package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^0-9-][0-9]{3}-[0-9]{2}-[0-9]{4}[^0-9-]`)
var str = `some document with 45-555-5462 in it
Another doc with 457-55-5462 in it
Doc with 4578-55-5462 in it
doc with 457-55-54623 in it
doc with 457-55-5462-23 in it`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}