import Foundation
let pattern = #"[^0-9-][0-9]{3}-[0-9]{2}-[0-9]{4}[^0-9-]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
some document with 45-555-5462 in it
Another doc with 457-55-5462 in it
Doc with 4578-55-5462 in it
doc with 457-55-54623 in it
doc with 457-55-5462-23 in it
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)