use strict;
my $str = 'some document with 45-555-5462 in it
Another doc with 457-55-5462 in it
Doc with 4578-55-5462 in it
doc with 457-55-54623 in it
doc with 457-55-5462-23 in it';
my $regex = qr/[^0-9-][0-9]{3}-[0-9]{2}-[0-9]{4}[^0-9-]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}